Hello There, Guest!

19-02-2012, 10:00 PM | Post: #1
Offline BoomShaBoom 
I downloaded successfully and have tried using it on Firefox and Chrome.
On Firefox, when I hit the 'Play Now' button, it just takes me to a screen that says "Game is Launching" and under that is a tutorial video on YouTube.
On Chrome, it takes me to the same place but a window pops up that says "there is already another updater instance running". What do I do?
Quote
20-02-2012, 12:51 AM | Post: #2
Offline Chaosdaemon 
having same issue, but I think it's a matter of just wait and see.
Quote
20-02-2012, 12:58 AM | Post: #3
Offline parthstar 
that happened to me
just uninstall and reinstall and i know it is a long time to reinstall but it doesn't crash so it is usefull
Quote
15-05-2012, 02:11 PM | Post: #4
Offline scrap_teh_neggah 
try restarting btw I only tried this on my bfh
Quote



Forum Jump:


WEB_PLAYER_PROFILE_ADD_TO_FRIENDS
WEB_PLAYER_PROFILE_REMOVE_FROM_FRIENDS
/en/ajax/checkFriendStatus
/en/ajax/friend
Battlefield Play4Free requires Windows XP or newer, sorry!
Please upgrade to Internet Explorer 5 or newer.
The 64bit version of Internet Explorer is not currently supported, please use the 32bit version.
Please upgrade to Firefox 1.5 or newer.
Please try Internet Explorer, Firefox or Chrome.
Battlefield Play4Free does not currently work with your browser.