Hello There, Guest!

06-04-2011, 11:59 PM | Post: #21
Offline Alntkno 
Sad I cannot even play today at all. I am having same issues. If it does load I get kicked in less than a minute. I have had this for 2 months and no problems until now.
07-04-2011, 12:04 AM | Post: #22
Offline Shenanigan 
I got my account in finally, but to test it I left the game on onam and now I cna't get back in. Once I do I will try leaving on a different map and see what happens.
07-04-2011, 12:06 AM | Post: #23
Offline Vegadonis 
(06-04-2011 11:57 PM)Shoudid Wrote:  
(06-04-2011 11:54 PM)Shenanigan Wrote:  
(06-04-2011 11:51 PM)Shoudid Wrote:  The fix for this is to reinstall.

Are we sure about this? I have two accounts and the one I am currently on is stuck on oman as with others, I get the invalid data, but I logged into a different account and it works golden. I dunno how reinstalling would help me if one account works and one does not.

Something from the devs sure wouldn't suck right about now.

I got 'invalid game data' every time I joined a server, reinstalled, now I can play.

Yea but that only works once. After you log off for awhile, come back, you get the same error.
07-04-2011, 12:07 AM | Post: #24
Offline mathheadf 
Its keeps happening to me too. I already reinstalled twice and I still keep getting the message INVALID GAME DATA. I was just starting to get the hang of flying too. What a shame.
07-04-2011, 12:19 AM | Post: #25
Offline Xzeo 
I am having this issue as well. It's a sore sight to see so many people having the same problem.

It'd be cool to have a staff member comment on some possible solutions other than reinstalling and deleting the cache, since both seem to not be working for everybody..

07-04-2011, 12:23 AM | Post: #26
Offline Kurann 
(06-04-2011 11:56 PM)Odious Wrote:  I reinstalled and it did nothing to help , not only that but for the last 3 hours it only attempts connection with one server and only the oman map.

This is the problem, its not oman, its not your computer. Some servers aren't updated and due to the lack of server version checking, server blacklists/browser, everyone having this problem is attempting to connect to a server that is (probably) dead and needs players, but because it isn't updated or it's modded or something else silly, you endlessly get a "Invalid Game Data" error. Yes, I have too, yes this falls under the "A" bug category.
07-04-2011, 12:23 AM | Post: #27
Offline legionair 
Angry yea im getting kicked & was playing this morning same deal invalid agme data ? plz post an answer.
07-04-2011, 12:27 AM | Post: #28
Offline BWDozer 
Same here guys guess my 24hrs of the new weapon is now worthless... I have posted here and on the FB page guess they are all on vacation no replies anywhere....
07-04-2011, 12:34 AM | Post: #29
Offline ChaosAurion707 
sounds like Oman server is down. sucks. way to fail BF.
07-04-2011, 12:38 AM | Post: #30
Offline ChaosAurion707 
I like how the only server it can figure out to try and put me in is oman too, stupid stupid game
07-04-2011, 12:43 AM | Post: #31
Offline sav1our 
ea support seems to be seriously lacking at the moment.
Still can't play the game, and was so excited to finally try it out too.
07-04-2011, 12:45 AM | Post: #32
Offline Vagitarian69 
Same issue here, too.
07-04-2011, 12:55 AM | Post: #33
Offline Tatino18 
I have the same problem @ Oman with "invalid game data"
07-04-2011, 01:03 AM | Post: #34
Offline Disastronaut 
Ditto. I assume this wasn't an issue in the closed beta?
07-04-2011, 01:07 AM | Post: #35
Offline xBattleHero 
it happens to me to. like oman is crewed for some reason. o-o
07-04-2011, 01:08 AM | Post: #36
Offline snake_eater94 
Just reinstall the game...

[Image: eAd35T]

Need Personal Assistance? Contact me HERE.
07-04-2011, 01:17 AM | Post: #37
Offline rsa5uke 
btw any 1 here a lvl 16 cause this started to happen after i get to lvl 16 >.<
07-04-2011, 01:23 AM | Post: #38
Offline Kurann 
reinstalling helps 1 time, don't bother, wait a while and sooner or later you'll get in a game, i waited maybe 20 mins and it got me in one
07-04-2011, 01:24 AM | Post: #39
Offline Phatrick 
Re-Installing does not fix this, already have tried Re-Installing several times.
07-04-2011, 01:24 AM | Post: #40
Offline DoomProphet 
All I had to do to resolve the issue was press CTRL+ALT+Delete and enter task-mngr. Then I went into "Processes"-Closed the BPF4Updater.exe and the iexplore.exe. I do not recommend shutting off your AV. The game runs fine with AV's. Shutting off your AV should only be a temporary fix. If there are any other iexplorers.exe running in your "Processes" then end those tasks too. I think the problem is that it loads a new process while the previous file is still running even after you shut the game down. Hope this helps.


[Image: 73242.gif]
(This post was last modified: 07-04-2011 01:29 AM by DoomProphet.)

Forum Jump:

Battlefield Play4Free requires Windows XP or newer, sorry!
Please upgrade to Internet Explorer 5 or newer.
The 64bit version of Internet Explorer is not currently supported, please use the 32bit version.
Please upgrade to Firefox 1.5 or newer.
Please try Internet Explorer, Firefox or Chrome.
Battlefield Play4Free does not currently work with your browser.